Module 39: Task UI: Creating a Task


	Lab 39-1
	Creating a Task

	Objective: To create a Siebel workflow process.
	 25-35 minutes


Instructions: 

In this lab, you will create a new task that guides a user through creating a new Service Request and associating an activity with the Service Request. In a real implementation, you would first design and create several custom applets to enter the service request fields of interest. Each applet would appear sequentially in the task. 

However since you have already learned how to configure applets, you will instead reuse existing applets in this lab, and concentrate on configuring the task related objects. 

This basic task uses two sequential views in which the user first enters Service Request information and then enters activity information. 

1. Before you start any configuration you will expose several object types that are not displayed by default in the object explorer.

a. If necessary, start Siebel Tools and log in as SADMIN/SADMIN to the Sample database.

b. Select View > Options. 

c. Click the Object Explorer tab. 

d. Deselect Task and then select it to display all of its child object types. 
e. Select Task Group. 
f. Expand View and select View Task Group. 

g. Click OK to close the window.

2. You will start creating the task by configuring the Task object in Siebel Tools.

a.  Create and lock a new project called Sample Tasks. 
b. Select File > New Object. 

c. Click the Task tab and select Task. 
d. Click OK to invoke the New Task Wizard. 

e. Enter the following

	Project
	Sample Tasks

	Task Name
	Sample Create New SR

	Display Name
	Create SR and Activity

	Business Object
	Service Request


Leave the default transient business component blank, as this task does not require one.

d. Click Finish. This creates a new Task object and invokes the Task Designer. Observe that a Start and End step have been automatically created and displayed in the designer.

3. You will now use the Task Designer to build the task.

a.  Add the following steps in order to the designer: Siebel Operation, Task View, Siebel Operation, Task View and another Task View. 
b. Move the end of the connector from the End step to the first Siebel Operation step. 

c. Drag additional connectors to the designer workspace and sequence the remaining steps making sure that each connector is anchored at both ends. The task should look like the 
following
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4. The first Siebel Operation step will be configured to create a new Service Request record while the second Siebel Operation step will be configured to create a new child Activity record. Configure the first Siebel Operation step as follows:

a. Select the step that immediately follows the Start step. 

b. Right-click and select View Properties Window. 
c. Enter the following properties:

d. Select the Second Siebel Operation Step (Siebel Operation 1).

e. Right-click and select View Properties Window.
f. Enter the following properties:

	Business Component
	Service Request

	Defer Write Record
	True

	Name
	Create SR

	Operation
	Insert

	Business Component
	Action

	Defer Write Record
	True

	Name
	Add Activity

	Operation
	Insert


g.   Save the configuration you created by clicking the Save button in the toolbar.

5. You will next create the Task View object that will be used to display the applet in which account information is entered.

a. Select File > New Object. 
b. Click the Task tab and select Task View. 
c. Click OK to invoke the New View Wizard. 
d. Enter the following.
	Project 
	Sample Tasks

	View Name
	Sample Service Request Task View

	Title
	Enter Service Request Details

	Business Object
	Service Request

	Upgrade Behaviour
	Admin


Note: Upgrade behavior is used to determine upgrade behavior for Siebel-provided objects. It is not used for custom objects. 

e. Click Next. 

f. Select View Basic for the Web layout template and click Next. 

g. Select the Service Request Detail Applet and move it to the selected applets column. Normally you would select an applet that you customized, but in this lab you will use an existing applet from the repository. 
h. Click Next.
i. Select No as you will not be adding a Task Applet, and click Next.
j. Select the Task Playbar Applet - Bottom and assign it as the bottom playbar applet.
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k. Click Next. 

l. Review the properties and click Finish. This invokes the View Web Template Layout editor. 

m. Verify that the Service Request - Detail applet appears on the template. If not, right-click on the editor surface and select Preview.

6. Repeat the previous step to create a second Task View object for entering the details of the associated activity.

a.  Use the following properties for the task view.
	Project 
	Sample Tasks

	View Name
	Sample Activities Task View

	Title
	Enter Activity Details

	Business Object
	Service Request

	Upgrade Behaviour
	Admin


b. Use the same view Web layout template (View Basic) but assign the Activity Form Applet to the template.

7. Repeat the previous step to create a third Task View object for giving a Summary of the information entered in previous two steps.

a. Use the following properties for the task view.
	Project 
	Sample Tasks

	View Name
	Sample SR Summary View

	Title
	Enter SR Summary

	Business Object
	Service Request

	Upgrade Behaviour
	Admin


b. Use the same view Web layout template (View Basic) but assign both the Activity Form Applet and Service Request Detail Applet to the template.

8. You will now bind the new task views you created to the Task View steps in the Task Flow.

a. Return to the Task Designer by clicking on the Task – Sample Create New SR – 0 tab. 
b. Select the Task View step that follows the Create SR step.
c. Right-click and select Bind Task View. 
d. Select Sample Service Request Task View, and click OK. 
e. Enter the following properties. If necessary right-click the task view and select View 
Properties Window.
	Disable Previous
	True

	Display Name – String Override
	Enter SR Details

	Forward Button Type
	Next


Since this is the first view in the task, you must disable the Previous button, as there is no previous view. 

f. Return to the task designer and select the Task View step that follows the second Siebel Operation step.

g. Right-click and select Bind Task View. 

h. Select Sample Activities Task View and click OK.
i. Enter the following properties. If necessary right-click the task view and select View Properties Window.

	Disable Previous
	False

	Display Name – String Override
	Enter Activity Details

	Forward Button Type
	Next


j. Save the configuration changes by clicking the Save button in the toolbar. You will now bind the Sample SR Summary View to the new task view step. 

i. Return to the Task Designer and select the last Task View step you added in this lab.
ii. Right-click and select Bind Task View.

iii.   Select Sample SR Summary View, and click. OK
iv. Make sure the task view is still selected and right-click and select View Properties Window.
	Disable Previous
	False

	Display Name – String Override
	Review Details and Submit

	Forward Button Type
	Submit


k. Save the configuration changes.
9. The designers have decided that this task should contain two chapters. You will create the chapters and then assign steps to each chapter.
a. Click on the designer background to display the multi-valued properties window (MVPW) for the task.

b. Click the Chapters tab and create two new chapter records in the MVPW.
	Name
	Display Name String - Override
	Sequence

	Chapter 1
	Enter new SR
	10

	Chapter 2


	Add Activity


	20




c. Right-click on the designer background and select Show Chapters (or press Ctrl+H). 

d. Select the following three steps by shift-clicking
	Start

	Create Service Request

	Sample Service Request Task View


e. Right-click and select Assign Chapter. 
f. Select Chapter 1 and click OK. 
g. Select the four remaining steps and assign them to Chapter 2. Verify that each step has the color of its chapter.


[image: image3.png]] Task - Sample Create new SR~ 2| ] rask st | ] Tok - Sanpl Crea e 50

M Task - Sample Create new SR- 2





h. Save your configuration changes.

10. You will next create a Task Group to which you will add this task. A task group   represents one or more tasks that are displayed as a group in the task pane.

a.  In the editor window click the Task List tab to display the object list editor. 
b. Select Task Group in the Object Explorer. 
c. Create a new Task Group record with:
	Name
	Sample SR Tasks

	Project
	Sample Tasks

	Display Name -String Override
	SR Tasks


c. Select Task Group :: Sample SR Tasks | Task Group Item.

d. Create a new record with:

	Action Invoked
	Sample Create new SR

	Type
	Task

	Sequence
	1


11. You will now associate the new task group with a view. This determines when the task group is visible in the client. In this case you will assign it to the Task Pane View in order that it be globally accessible.

a. Select View :: Task Pane View | View Task Group. 

b. If necessary, lock the project by selecting Tools > Lock Project. 

c.    Add a new record with
	Task Group
	Sample SR Tasks

	Sequence
	1


12. You are now ready to compile the new configured objects into the client SRF file.

a. Make sure that Siebel Call Center is closed. 

b. Select Tools > Compile Projects. 

c. Make sure that only the Sample Tasks and Task UI Framework (SWE) projects are selected. 
d. Compile these projects into D:\Siebel\Client\OBJECTS\ENU\siebel_sia.srf.

13. You are now ready to publish the task into the client (runtime) database.

a. Click the Task Sample Create new SR - 0 tab in the editor to return to the Task Designer. 

b. Right-click on the designer background and select Validate. 
c. Click Start. 
d. Verify that no errors occur and click Cancel. If any errors are displayed, make sure that you fix them before you continue. 
e. Select Task :: Sample Create new SR. 
f. Click the Publishn button in the WF/Task Editor toolbar to publish the task. Since you just validated the task, click Yes to continue. 
g. Observe that the Status property changes to Completed. You will not be able to edit this task without first revising it.

14. You will now administer the task in the client, with the first step being to activate the task. 

a. Double-click on the Siebel Call Center shortcut on the desktop. Login as SADMIN/SADMIN connecting to Sample database.
b. Navigate to Administration - Business Process > Task Deployment. 
c. Select Sample Create new SR in the Published Tasks applet and click Activate. Observe that the task is added to the Active tasks applet. 

15. Next you will register the task and assign it to a responsibility so that users will be able to invoke it.

a.  Navigate to Administration - Application > Tasks.

b. In the Registered Tasks applet create a new record and select the Sample Create new SR task from the picklist.

c. In the lower Responsibilities applet, click New and add the Siebel Administrator responsibility. 

d. Make sure the Allow Delete and Allow Transfer flags are checked to permit the user to either delete or transfer a paused task in the user's inbox. 

e. Click Clear Cache to update the cached responsibilities. 
f. Log out of Siebel Call Center and then log back in as SADMIN/SADMIN.
16. You will finally verify that the task was successfully deployed to the client and works as designed.

a.  In Siebel Call Center, click the Tasks button [image: image4.png]


 in the toolbar, to display the task pane. Verify that the task you deployed is displayed.
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b.  Click the Create SR and Activity link. 

c.  Verify that the first task view appears and that the task pane now displays both chapters. Also observe that the Previous button is disabled.
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d.   Enter a SR name and other details. 

e.   Click the Next button
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e. Verify that the Service Request name appears in the Activity Contacts. 

f. Enter an activity name and click Next. 
g. Ensure that the screen looks like this, with the Summary view comprising the Service Request and Activity details.
h. Click Submit.
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j.    Navigate to the My Service Requests view, select the service request you created, drill down on it and navigate to the service request activity view. Verify that the new SR and activity now appear in the regular Siebel UI.
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